Can't solomine from an external computer


I have two computers, both running W10. One has the magi wallet installed, all up-to-date and synced, the other has m-minerd installed. They are in the same private network: the one with the wallet has ip The magi.conf file is in C:\Users\MyUser\AppData\Roaming\Magi\magi.conf. It has the following contents:


The changes I do here seem to affect the server, so the file is read correctly. Also, from the logs, I couldn’t find any problem with the server binding with the port, but I could be wrong here. Then, I run this command on the other laptop, from which the mining is supposed to be happening:

m-minerd -o --no-longpoll --no-getwork --no-stratum --coinbase-addr=myaddress -u someuser -p somepassword -e 100 -t 8
The command is met with the usual “Thread n bound to processor n” and then with a message, that the http request returned with a 403 Forbidden error.

Things I’ve tried:

Changed the rpcallowip to the following values:,, and the ip of the laptop itself.

Removed one at a time the daemon, listen and rpcallowip lines from the config file. I’ve heard that, to allow all IPs, I can remove the rpcallowip altogether. Even if that’s not the case, I tried with the above mentioned IPs and still it won’t work.

The firewall on the laptop with the wallet is most definitely turned off.

It works if I mine from the computer with the wallet with the following command: m-minerd -o --no-longpoll --no-getwork --no-stratum --coinbase-addr=myaddress -u someuser -p somepassword -e 100 -t 4

I am at a loss for how to continue, it seems I’ve done everything and every piece of advice I could find on the internet. What do I do?